Hello everyone,
This is my first question on technet, I have been trying to set up Windows Deployment Services in my lab at home for M.C.S.E Desktop infrastructure and Private Cloud training.
This is my setup:
7 = 2.4 GHZ dual quad core Xeon sever blades from Supermicro with 16 GB Ram on each
3 = Cisco 1841 Routers IOS 12.4
3 = Cisco 2950 Switches
Ok here is whats going on I am not able to connect to the Windows Deployment Services when PXE booting my machines get an IP a response for the boot\x64\wdsnbp.com but then I get a "No Response from Windows Deployment Services" error and if I hit F12 I get
Windows failed to start (etc.)
File: \Boot\BCD
Status: 0xc000000f
Info: An error occurred while attempting to read the boot configuration data.
I have the WDS Authorized on the DHCP the scope options are set for
066 192.168.2.110 my WDS server
067 boot\x64\wdsnbp.com
My DHCP server and WDS server are on different machines. I have followed Greg Shield's CBT Nuggets and petnetlive.com videos but I get nowhere I need some help I have read almost every thread I could find I hope I can find someone who has figured this out.
Here are my router and switch configs:
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname MCSESwitch
!
logging buffered 56000 warnings
aaa new-model
enable secret 5
!
username castro privilege 15 password 7
ip subnet-zero
!
ip domain-name MCSESwitch
ip ssh time-out 60
ip ssh authentication-retries 3
ip ssh version 2
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
spanning-tree uplinkfast
!
!
!
!
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
spanning-tree portfast
spanning-tree bpdufilter enable
!
interface FastEthernet0/2
switchport access vlan 2
switchport mode access
spanning-tree portfast
spanning-tree bpdufilter enable
!
interface FastEthernet0/3
switchport access vlan 2
switchport mode access
spanning-tree portfast
spanning-tree bpdufilter enable
!
interface FastEthernet0/4
switchport access vlan 2
switchport mode access
spanning-tree portfast
spanning-tree bpdufilter enable
!
interface FastEthernet0/5
switchport access vlan 2
switchport mode access
spanning-tree portfast
spanning-tree bpdufilter enable
!
interface FastEthernet0/6
switchport access vlan 2
switchport mode access
spanning-tree portfast
spanning-tree bpdufilter enable
!
interface FastEthernet0/7
switchport access vlan 2
switchport mode access
spanning-tree portfast
spanning-tree bpdufilter enable
!
interface FastEthernet0/8
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/9
description WiFi
switchport access vlan 2
switchport mode access
spanning-tree portfast
spanning-tree bpdufilter enable
!
interface FastEthernet0/10
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/16
description RouterTrunk
switchport access vlan 2
switchport trunk allowed vlan 2-4,1002-1005
switchport mode trunk
spanning-tree portfast
ip dhcp snooping trust
!
interface FastEthernet0/17
switchport access vlan 2
switchport mode access
spanning-tree portfast
spanning-tree bpdufilter enable
!
interface FastEthernet0/18
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 2
switchport mode access
spanning-tree portfast
spanning-tree bpdufilter enable
!
interface FastEthernet0/24
switchport access vlan 2
switchport mode access
spanning-tree portfast
spanning-tree bpdufilter enable
ip dhcp snooping trust
!
interface Vlan1
description DATA Vlan
no ip address
no ip route-cache
shutdown
!
interface Vlan2
description DHCP Vlan
ip address 192.168.2.2 255.255.255.0
no ip route-cache
!
interface Vlan3
description PXE Vlan
ip address 192.168.3.2 255.255.255.0
no ip route-cache
shutdown
!
interface Vlan4
description GUEST Vlan
ip address 192.168.4.2 255.255.255.0
no ip route-cache
shutdown
!
ip http server
ip http authentication local
line con 0
privilege level 15
password 7
logging synchronous
line vty 0 4
privilege level 15
password 7
transport input ssh
line vty 5 15
privilege level 15
password 7
transport input ssh
!
!
end
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname MCSERouter
!
boot-start-marker
boot-end-marker
!
enable secret 5
!
aaa new-model
!
!
!
aaa session-id common
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool pxe
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 192.168.2.100 192.168.2.110
option 67 ascii "boot\x64\wdsnbp.com"
option 66 ip 192.168.2.110
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
username xxxx privilege 15 password 7
!
!
ip ssh time-out 60
ip ssh version 2
!
!
!
!
interface FastEthernet0/0
no ip address
ip helper-address 192.168.2.100
ip helper-address 192.168.2.110
duplex auto
speed auto
!
interface FastEthernet0/0.2
description DHCP VLAN
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
ip helper-address 192.168.2.110 <----WDS
ip helper-address 192.168.2.100 <----DHCP, DNS, AD
ip helper-address 192.168.2.1 <----Gateway
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/0.3
description PXE VLAN
encapsulation dot1Q 3
ip address 192.168.3.1 255.255.255.0
ip helper-address 192.168.2.110
ip helper-address 192.168.2.100
ip helper-address 192.168.2.1
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/0.4
description GUEST VLAN
encapsulation dot1Q 4
ip address 192.168.4.1 255.255.255.0
ip helper-address 192.168.2.110
ip helper-address 192.168.2.100
ip helper-address 192.168.2.1
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1
description Internet
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
!
!
ip http server
ip http authentication local
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
access-list 1 permit 192.168.3.0 0.0.0.255
access-list 1 permit 192.168.4.0 0.0.0.255
access-list 100 permit udp 192.168.2.0 0.0.0.255 eq bootps any
access-list 100 permit udp 192.168.2.0 0.0.0.255 eq bootpc any
access-list 100 permit udp 192.168.2.0 0.0.0.255 eq domain any
access-list 100 permit udp 192.168.2.0 0.0.0.255 eq tftp any
access-list 100 permit udp 192.168.2.0 0.0.0.255 eq 4010 any
access-list 100 permit udp 192.168.2.0 0.0.0.255 eq 4011 any
access-list 100 permit udp 192.168.2.0 0.0.0.255 eq 5040 any
access-list 100 permit tcp 192.168.2.0 0.0.0.255 eq domain any
access-list 100 permit tcp 192.168.2.0 0.0.0.255 eq 4010 any
access-list 100 permit tcp 192.168.2.0 0.0.0.255 eq 4011 any
access-list 100 permit tcp 192.168.2.0 0.0.0.255 eq 5040 any
access-list 101 permit tcp host 50.138.90.250 eq 3389 192.168.2.0 0.0.0.255
!
!
!
!
control-plane
!
!
line con 0
password 7
logging synchronous
line aux 0
line vty 0 4
password 7
transport input telnet ssh
!
scheduler allocate 20000 1000
end
Any help would be greatly appreciated....